Gaming Underground Network

Come for the Mods, Stay for the Community!
 
HomeCalendarFAQMemberlistUsergroupsRegisterLog in
Info Panel
________________

Profile Image Guidelines
December 2016
MonTueWedThuFriSatSun
   1234
567891011
12131415161718
19202122232425
262728293031 
CalendarCalendar

Share | 
 

 Custom Texture not working

View previous topic View next topic Go down 
AuthorMessage
lordniti2



Posts : 269
Join date : 2014-03-15
Location : The BatCave

PostSubject: Custom Texture not working   Mon Dec 14, 2015 10:35 pm

Hello Everyone recently I have ran into some trouble while creating custom textures for hk-47 in new vegas I created the texture fine but when it came to preview it in the geck my texture did not appear instead it was completely black I used paint.net to create the texture if anyone wants to assist I have included the link below

Code:
http://www.mediafire.com/download/fyeukc3g3krg33k/hk47+gold+tint+2.dds

_________________
When Life Gives You Lemons Keep Em Cause hey free lemons
Back to top Go down
View user profile
chemmy



Posts : 54
Join date : 2014-03-17
Age : 34
Location : virginia, USA

PostSubject: Re: Custom Texture not working   Tue Dec 15, 2015 7:23 am

i opened it up and re saved it with photoshop, give it a try now

Click Here
Back to top Go down
View user profile
AceGoober



Posts : 294
Join date : 2015-07-02
Age : 50
Location : Northern California

PostSubject: Re: Custom Texture not working   Tue Dec 15, 2015 7:23 pm

@lordniti2
@chemmy

Neither of the links posted go directly to either of the files. Would you all be so kind as to fix them, please? Thanks!

_________________
i7 4790k @ 4Ghz, 4.4 Turbo
Asus Z97-AR
Custom Liquid Cooling
Patriot 16 GB (4 x 8 GB) 2133 @ 11-11-11-27
eVGA GTX Titan X @ Stock
Samsung EVO 1 TB SSD - O/S
Samsung EVO 1 TB SSD - Storage
Seasonic X-1250 Power Supply
Thermaltake Core X9 Chassis
Samsung UD590 3840 x 2160
Windows 7 Ultimate x64
Back to top Go down
View user profile
chemmy



Posts : 54
Join date : 2014-03-17
Age : 34
Location : virginia, USA

PostSubject: Re: Custom Texture not working   Tue Dec 15, 2015 9:45 pm

i see that, was working fine last night until that crap started happening, stupid adf.ly, and i see what's going on now, it's removing the / between .com and download, sending you to adf.ly first, now it will take you right to it.

Code:
http://www.mediafire.com/download/6x16kv2nvoto452/hk47+gold+tint+2.dds
Back to top Go down
View user profile
lordniti2



Posts : 269
Join date : 2014-03-15
Location : The BatCave

PostSubject: Re: Custom Texture not working   Wed Dec 16, 2015 7:07 am

Thanks I downloaded it and sadly nothing has changed the textures still show up as black Sad

_________________
When Life Gives You Lemons Keep Em Cause hey free lemons
Back to top Go down
View user profile
Cpt.Rex



Posts : 2761
Join date : 2014-02-23
Age : 39
Location : Germany

Character sheet
Name: Character
Faction:
Level:

PostSubject: Re: Custom Texture not working   Wed Dec 16, 2015 7:14 am

okay, i downloaded your texture and resaved it with paint.net. try if this works...

Code:
http://www.mediafire.com/download/pdbdb1y55q9qb6z/hk47+gold+tint+2.rar

_________________
Are you new here? Then check this out ... FAQ and Rules & Guidelines
Back to top Go down
View user profile
lordniti2



Posts : 269
Join date : 2014-03-15
Location : The BatCave

PostSubject: Re: Custom Texture not working   Wed Dec 16, 2015 10:07 pm

that did the trick rex thanks although what I don't get is I made the texture using paint.net and saved it using paint.net

_________________
When Life Gives You Lemons Keep Em Cause hey free lemons
Back to top Go down
View user profile
Cpt.Rex



Posts : 2761
Join date : 2014-02-23
Age : 39
Location : Germany

Character sheet
Name: Character
Faction:
Level:

PostSubject: Re: Custom Texture not working   Wed Dec 16, 2015 10:19 pm

hm.. i have no idea. maybe it is because of your export setting. when i export my dds textures i use always this setting here..
Spoiler:
 
that works very well on my end. the geck and the game show no problems with it.

_________________
Are you new here? Then check this out ... FAQ and Rules & Guidelines
Back to top Go down
View user profile
dazzerfong



Posts : 588
Join date : 2014-04-04
Age : 21
Location : Sydney, Australia

PostSubject: Re: Custom Texture not working   Wed Dec 16, 2015 10:55 pm

It's black because you don't have mipmaps. Don't worry about it, it usually shows up in FNV/FO3 anyway.

Also, don't use DXT5 unless you have an alpha map: you doubled your texture memory for no benefit. Stick to DXT1 otherwise.

_________________
Back to top Go down
View user profile
Voivre



Posts : 354
Join date : 2014-04-20
Age : 26
Location : Las Vegas, NV

PostSubject: Re: Custom Texture not working   Thu Dec 17, 2015 3:24 am

@dazzerfong wrote:
It's black because you don't have mipmaps. Don't worry about it, it usually shows up in FNV/FO3 anyway.

Also, don't use DXT5 unless you have an alpha map: you doubled your texture memory for no benefit. Stick to DXT1 otherwise.

In photoshop, how does one choose dxt5 or dxt1?

_________________
Back to top Go down
View user profile
mpaz96



Posts : 1497
Join date : 2014-08-12
Age : 20
Location : Colombia

PostSubject: Re: Custom Texture not working   Thu Dec 17, 2015 3:58 am

@Voivre wrote:
@dazzerfong wrote:
It's black because you don't have mipmaps. Don't worry about it, it usually shows up in FNV/FO3 anyway.

Also, don't use DXT5 unless you have an alpha map: you doubled your texture memory for no benefit. Stick to DXT1 otherwise.

In photoshop, how does one choose dxt5 or dxt1?

It's simple, you just click on "Save as" and save your file (i'm guessing it's a .dds file). After that this should appear and you just choose DXT5.

Spoiler:
 

That's it, hope it helps.

_________________
Back to top Go down
View user profile
Voivre



Posts : 354
Join date : 2014-04-20
Age : 26
Location : Las Vegas, NV

PostSubject: Re: Custom Texture not working   Thu Dec 17, 2015 4:01 am

@mpaz96 wrote:
@Voivre wrote:
@dazzerfong wrote:
It's black because you don't have mipmaps. Don't worry about it, it usually shows up in FNV/FO3 anyway.

Also, don't use DXT5 unless you have an alpha map: you doubled your texture memory for no benefit. Stick to DXT1 otherwise.

In photoshop, how does one choose dxt5 or dxt1?

It's simple, you just click on "Save as" and save your file (i'm guessing it's a .dds file). After that this should appear and you just choose DXT5.

Spoiler:
 

That's it, hope it helps.

When I go to save, this is all I see..

_________________
Back to top Go down
View user profile
mpaz96



Posts : 1497
Join date : 2014-08-12
Age : 20
Location : Colombia

PostSubject: Re: Custom Texture not working   Thu Dec 17, 2015 4:26 am

@Voivre What version of photoshop do you have? Also, did you install NVIDIA Texture Tools for Adobe Photoshop?

This one here:

https://developer.nvidia.com/nvidia-texture-tools-adobe-photoshop

_________________
Back to top Go down
View user profile
Voivre



Posts : 354
Join date : 2014-04-20
Age : 26
Location : Las Vegas, NV

PostSubject: Re: Custom Texture not working   Thu Dec 17, 2015 4:37 am

@mpaz96 wrote:
@Voivre What version of photoshop do you have? Also, did you install NVIDIA Texture Tools for Adobe Photoshop?

This one here:

https://developer.nvidia.com/nvidia-texture-tools-adobe-photoshop

I think that's what Dazzerfong had me delete, but I may be mistaken.

_________________
Back to top Go down
View user profile
mpaz96



Posts : 1497
Join date : 2014-08-12
Age : 20
Location : Colombia

PostSubject: Re: Custom Texture not working   Thu Dec 17, 2015 6:03 am

@Voivre wrote:
@mpaz96 wrote:
@Voivre What version of photoshop do you have? Also, did you install NVIDIA Texture Tools for Adobe Photoshop?

This one here:

https://developer.nvidia.com/nvidia-texture-tools-adobe-photoshop

I think that's what Dazzerfong had me delete, but I may be mistaken.

I don't know any reason why this would be deleted. Thinking

You should ask him anyway though, since he knows more about this stuff than me.

_________________
Back to top Go down
View user profile
dazzerfong



Posts : 588
Join date : 2014-04-04
Age : 21
Location : Sydney, Australia

PostSubject: Re: Custom Texture not working   Thu Dec 17, 2015 6:56 am

@Voivre: BC3 is the same as DXT5. You chose 'Color + Alpha', so that's all you have. If you want BC1 (or DXG1), you need to select 'Color' only.

@mpaz96: I don't use the Nvidia DDS anymore because it doesn't support BC7 and BC5, which FO4 uses. Worse, if you open up a BC5 with Nvidia DDS, it imports it incorrectly: rather than an empty blue channel (as BC5 only contains R and G), it decodes it incorrectly, thus the plentiful array of faded blue normal map imports.

So, to summarise into a neat table:

FO3/FNV/SkyrimFO4
Normal MapDXT5/BC3BC5
DiffuseDXT1/BC1BC7
Diffuse w/ transparencyDXT5/BC3BC7

Thus, if you want to get FO4 ready, use the Intel Texture Works tool instead. If you don't have Photoshop, you can use TexConv instead.

For more info, check this this out.

_________________
Back to top Go down
View user profile
chemmy



Posts : 54
Join date : 2014-03-17
Age : 34
Location : virginia, USA

PostSubject: Re: Custom Texture not working   Thu Dec 17, 2015 5:39 pm

I had a feeling that the nvidia dds plugin wasn't saving the textures right for FO4, and is this the one dazzer, not really sure if it is

Code:
http://gametechdev.github.io/ITW-Beta-Test/
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Custom Texture not working   Today at 1:58 am

Back to top Go down
 

Custom Texture not working

View previous topic View next topic Back to top 
Page 1 of 1

 Similar topics

-
» sky box texture not working
» Installing custom (fan-made) maps (SWBF2).
» playable custom heads
» Dragon Rider a Stikfas Custom
» Thumper - a stikfas custom

Permissions in this forum:You cannot reply to topics in this forum
Gaming Underground Network :: Fallout :: Troubleshooting-