Gaming Underground Network

Come for the Mods, Stay for the Community!
 
HomeCalendarFAQMemberlistUsergroupsRegisterLog in
Info Panel
________________
FO MOD MASTER THREAD
TES MOD MASTER THREAD

________________


________________
_
August 2017
MonTueWedThuFriSatSun
 123456
78910111213
14151617181920
21222324252627
28293031   
CalendarCalendar

Share | 
 

 Normal and Spec Maps not working in GECK (Solved)

View previous topic View next topic Go down 
AuthorMessage
DenyingBody

avatar

Posts : 10
Join date : 2014-09-06
Age : 21

PostSubject: Normal and Spec Maps not working in GECK (Solved)   Tue Apr 18, 2017 7:04 am

Hello all!

So, I need some serious help. I've been working on several projects in which I can't get the textures to work properly in the GECK. I have this problem where if I have a modded armor and I tweak the diffuse then make a new Texture Set with the original Normals and Specular maps, and apply my Tex Set to the model in the GECK it completely screws up the textures making them shiny. I don't touch the Normal or specular maps, yet it acts like I have neither in the Texture Set. I've also tried just linking the new diffuse straight to the model through Nifskope, but I get the same result when I add the edited model into the Geck. It also seems to only affect areas of the armor that are supposed to shine. But again, it makes the shine WAY more than the original. I've created new Normals and Specular maps to try and fix this but it either makes it a thousand times worse, or too dark to show any of the detail.

Here are some examples.

Here's how the original armor looks with nothing done to the textures or anything in the GECK:


Here's how the original textures look:




Here's how the armor looks when I use the original textures to create a Texture set in the GECK:


And here's how the armor looks with my edited Normals:


With Said Normals:


Any help would be wonderful. I've been struggling with this for three days now and I just can't figure out where i'm going wrong. Thank you to whomever may be reading this for at least taking the time to.. well.. read this!

-DenyingBody


Last edited by DenyingBody on Wed Apr 19, 2017 5:27 am; edited 1 time in total
Back to top Go down
View user profile
superpele

avatar

Posts : 182
Join date : 2015-05-14
Age : 26
Location : Latvia

PostSubject: Re: Normal and Spec Maps not working in GECK (Solved)   Tue Apr 18, 2017 8:20 am

Does the normal map have an alpha channel? Also, spec maps should never look that busy, you can just color the places you need to shine with a simple dark grey.

_________________
My mods for New Vegas:
Back to top Go down
View user profile
aarius

avatar

Posts : 1437
Join date : 2015-06-07
Age : 18
Location : home

Character sheet
Name: sᴏᴜʟʟᴇss
Faction: ᴅɪsᴀᴠᴏᴡᴇᴅ
Level: ᴅɪsᴄʀᴇᴛᴇ

PostSubject: Re: Normal and Spec Maps not working in GECK (Solved)   Tue Apr 18, 2017 8:32 am

Back to top Go down
View user profile
DenyingBody

avatar

Posts : 10
Join date : 2014-09-06
Age : 21

PostSubject: Normal and Specular Maps not working correctly in GECK   Wed Apr 19, 2017 4:50 am

@Superpele

The normal does, and I've already tried multiple attempts at making a new specular map. The problem isn't specifically the one armor. This happens to any modded armor (and more than likely weapon and etc.) I try to make a texture set for in the GECK. I'll use the same exact textures as included in the mod and it always creates this horrid shine.

@aarius

Also thank you aarius. That's not exactly what I needed right now but your video will be extremely valuable in my future projects.

[WAIT!!!]

I've fixed it! It appears that I didn't add the "effect" texture when creating the Texture set in the GECK. It had nothing to do with the Normals or Specular maps at all! thank you Superpele and aarius for the help. Even though it ended up not being the problem I was having, your help will help me down the line when it comes to making Normal and Spec maps. So thank you, thank you, thank you!

Have a great day guys!

-DenyingBody
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Normal and Spec Maps not working in GECK (Solved)   

Back to top Go down
 

Normal and Spec Maps not working in GECK (Solved)

View previous topic View next topic Back to top 
Page 1 of 1

 Similar topics

-
» Installing custom (fan-made) maps (SWBF2).
» Garden Of Eden Creation Kit has stopped working
» TBC Quest-Maps
» what maps you wanted converted to UT3
» P1 Spec Lola-Jaguar Testing at Mont Serrat.

Permissions in this forum:You cannot reply to topics in this forum
Gaming Underground Network :: Fallout :: Troubleshooting-